summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86c94d834d36..03ede7bdd129 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=alephone-git
-pkgver=1.6.1.r5745.e1e51743
+pkgver=1.7b1.r5879.2da0b706
pkgrel=1
pkgdesc='A free, enhanced port of the classic FPS "Marathon 2" by Bungie Software (development version)'
arch=('i686' 'x86_64')
@@ -17,8 +17,10 @@ optdepends=('alephone-eternalx: community-made scenario'
'alephone-marathon: M1A1 data converted for AlephOne'
'alephone-marathon2: original data for Marathon 2: Durandal')
makedepends=('git' 'boost' 'mesa' 'icoutils' 'autoconf-archive')
-source=("git+https://github.com/Aleph-One-Marathon/alephone")
-md5sums=('SKIP')
+source=("git+https://github.com/Aleph-One-Marathon/alephone"
+ "xdg_data_dir.patch")
+md5sums=('SKIP'
+ '296df23c9e47fc772e5e6e1b62c50827')
pkgver() {
cd alephone/Source_Files/Misc
@@ -29,6 +31,9 @@ pkgver() {
prepare() {
cd alephone
+ # Use XDG Base Directory specification for user data
+ patch -Np1 -i "${srcdir}/xdg_data_dir.patch"
+
# convert the windows icons
cd Resources/Windows
icotool -x -w 48 alephone.ico -o "$srcdir"/alephone.png