summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5e983acba74..acb979b1452d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=algernon
pkgver=1.12.5
-pkgrel=1
-pkgdesc='Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
+pkgrel=2
+pkgdesc='Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
arch=(x86_64)
url='https://algernon.roboticoverlords.org/'
license=(MIT)
-makedepends=(git go upx)
+makedepends=(git go)
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend'
'redis: For using the Redis database backend')
@@ -17,7 +17,6 @@ md5sums=('SKIP')
prepare() {
cd "$pkgname"
go build -mod=vendor -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
- upx algernon
}
package() {