summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7dfc0449edf..ba8619449fc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=alice-vision
#fragment="#commit=5bea89263bf5f3ed623b8e6e6a5f022a0ed9c1de"
_fragment="#branch=develop"
-pkgname=${_name}
+pkgname=${_name}-git
pkgver=2.0.0.r8.g62c55519
pkgrel=1
pkgdesc="Photogrammetric Computer Vision Framework which provides a 3D Reconstruction and Camera Tracking algorithms"
@@ -11,17 +11,19 @@ arch=('i686' 'x86_64')
url="http://alicevision.github.io/"
license=('MPL2' 'MIT')
groups=()
+conflicts=(alice-vision)
+provides=(alice-vision)
depends=('openblas-lapack' 'gflags' 'glfw-x11' 'alembic' 'boost-libs' 'openexr' 'openimageio' 'opengv-git' 'flann' 'coin-or-coinutils' 'coin-or-clp' 'coin-or-lemon' 'coin-or-osi' 'google-glog')
makedepends=('boost' 'eigen' 'ceres-solver' 'cuda' 'git' 'cmake' 'magma')
source=("${pkgname}::git+https://github.com/alicevision/AliceVision.git${_fragment}"
- "osi_clp::git+https://github.com/alicevision/osi_clp.git"
"ute_lib::git+https://github.com/alicevision/uncertaintyTE.git"
"geogram::git+https://github.com/alicevision/geogram.git"
+ "submodule.patch"
)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'eb62c8be5a0d7ce537a928314c9d0028')
_CMAKE_FLAGS=(
-DCMAKE_INSTALL_PREFIX=/usr
@@ -46,8 +48,8 @@ pkgver() {
prepare() {
cd ${srcdir}/${pkgname}
git submodule init
- git config submodule.src/dependencies/osi_clp.url ${srcdir}/osi_clp
git submodule update
+ git apply ${srcdir}/submodule.patch
}
@@ -68,13 +70,6 @@ build() {
make DESTDIR="../geogram_bin" install
cd ..
-# msg2 "Build Osi library"
-# mkdir -p osi_build && cd osi_build
-# cmake -DCMAKE_INSTALL_PREFIX=/ ../osi_clp
-# make
-# make DESTDIR="../osi_bin" install
-# cd ..
-
msg2 "Build AliceVision library"
mkdir -p build && cd build
cmake ${_CMAKE_FLAGS[@]} -DUNCERTAINTYTE_DIR=${srcdir}/ute_bin -DGEOGRAM_INSTALL_PREFIX=${srcdir}/geogram_bin ../${pkgname}