summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c7ab83a8872..2c87d47a3a13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Contributor: Gena genaloner@gmail.com
pkgbase=alienfx
pkgname=alienfx
-pkgver=2.0.5
-pkgrel=7
+pkgver=2.1.1
+pkgrel=1
pkgdesc="CLI and GUI utility to control the lighting effects of your Alienware computer written in Python."
arch=('any')
url="https://github.com/trackmastersteve/alienfx"
license=('GPLv3')
-makedepends=('python2-setuptools')
-depends=('python2' 'python2-cairo' 'python2-gobject' 'python2-pyusb')
-source=("git+https://github.com/trackmastersteve/alienfx")
-md5sums=('SKIP')
+makedepends=('python-setuptools')
+depends=('python' 'python-cairo' 'python-gobject' 'python-pyusb' 'python-future')
+source=("https://github.com/trackmastersteve/alienfx/archive/v2.1.1.zip")
+sha256sums=('eb307e7132c6830c7e98068af9bf4dfac023e76fa386b8704016e373a77a39d0')
package() {
- cd "${srcdir}/${pkgbase}"
- python2 setup.py clean
- python2 setup.py install --root="${pkgdir}"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
+ python setup.py clean
+ python setup.py install --root="${pkgdir}"
install -Dm755 ${pkgbase}/data/etc/udev/rules.d/10-alienfx.rules ${pkgdir}/etc/udev/rules.d/10-alienfx.rules
chmod a+x ${pkgdir}/usr/share/applications/alienfx.desktop