summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dad457e6574..9595bd6146c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jia Li <lijia1608@gmail.com>
pkgname=alpscore
-pkgver=0.5.5
+pkgver=1.0.0
pkgrel=1
pkgdesc="ALPS Core libraries for numerical simulations of condensed matter systems."
arch=(i686 x86_64)
@@ -10,13 +10,17 @@ depends=('cmake' 'boost' 'hdf5')
provides=($pkgname=$pkgver)
conflicts=(alpscore-git alpscore-openmpi alpscore-openmpi-git alps)
source=("https://github.com/ALPSCore/ALPSCore/archive/v$pkgver.tar.gz")
-md5sums=('8f744ce2a8bffef750eb4500181dc59d')
+md5sums=('ca602ac28478cc514d34fdd98513ab2e')
build() {
cd "ALPSCore-$pkgver"
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DTesting=OFF -DDocumentation=OFF ..
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DTesting=OFF \
+ -DDocumentation=OFF \
+ ..
make
}