summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb2325d12645..317b663092b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# $Id: PKGBUILD 332903 2018-08-24 06:37:15Z arojas $
+# $Id$
# Maintainer: Ronald van Haren <ronald@archlinux.org>
# Maintainer: Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: damir <damir@archlinux.org>
pkgname=amarok
-pkgver=2.9.0.git20180816
-_commit=8f5ef80
-pkgrel=4
+pkgver=2.9.0
+pkgrel=2
pkgdesc="The powerful music player for KDE"
arch=(x86_64)
url="http://amarok.kde.org/"
license=(GPL2 LGPL2.1 FDL)
-depends=(mariadb taglib-extras libofa kcmutils kdnssd knewstuff kirigami2 threadweaver ktexteditor qt5-webengine liblastfm-qt5)
-makedepends=(extra-cmake-modules loudmouth libmtp libmygpo-qt5 gdk-pixbuf2 libgpod git knotifyconfig)
+depends=(kdebase-runtime mariadb taglib-extras liblastfm ffmpeg libofa qjson qtscriptgenerator)
+makedepends=('automoc4' 'cmake' 'libgpod' 'libmtp' 'loudmouth' 'libmygpo-qt' 'qca-qt4')
optdepends=('libgpod: support for Apple iPod audio devices'
'libmtp: support for portable media devices'
'loudmouth: backend needed by mp3tunes for syncing'
'ifuse: support for Apple iPod Touch and iPhone'
- 'libmygpo-qt5: gpodder.net Internet Service')
-#source=("http://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
-source=(git://git.kde.org/amarok.git#commit=$_commit)
-sha256sums=('SKIP')
+ 'libmygpo-qt: gpodder.net Internet Service'
+ 'gst-libav: MP3 codecs'
+ 'qca-qt4: Ampache support')
+source=("http://download.kde.org/stable/$pkgname/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
+sha256sums=('e3678de79db36956bc8588b9905726ace1b9188e7fdf89eaea265f1cb03116fd'
+ 'SKIP')
validpgpkeys=(D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heirecka@exherbo.org>
prepare() {
@@ -30,10 +31,12 @@ prepare() {
build() {
cd build
- cmake ../$pkgname \
+ cmake ../$pkgname-$pkgver \
+ -DKDE4_BUILD_TESTS=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_TESTING=OFF
+ -DWITH_NepomukCore=OFF \
+ -DWITH_Soprano=OFF \
+ -DWITH_QTWEBKIT=OFF
make
}