summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5177ebf9c13f..90e9ba174b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=ampache-git
_gitname=ampache
pkgver=3.8.1.7.g799165a
-pkgrel=1
+pkgrel=2
pkgdesc="A PHP-based tool for managing and playing your audio/video files via a web interface"
arch=('i686' 'x86_64')
url="http://www.ampache.org/"
license=('GPL')
depends=('mariadb>=5.0' 'php>=5.4' 'curl')
-makedepends=('git')
+makedepends=('git' 'php-composer')
optdepends=('ffmpeg: all transcoding/downsampling'
'lame: mp3 transcoding/downsampling'
'vorbis-tools: ogg transcoding/downsampling'
@@ -36,6 +36,8 @@ package() {
cd ${srcdir}/${_gitname}
mkdir -p ${pkgdir}/srv/http/${_gitname}
cp -a * ${pkgdir}/srv/http/${_gitname}/
+ cd ${pkgdir}/srv/http/${_gitname}
+ composer install --prefer-source --no-interaction
mkdir -p ${pkgdir}/usr/share/doc/${_gitname}
install -D -m644 ${srcdir}/nginx-example.conf ${pkgdir}/usr/share/doc/${_gitname}/
}