summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index afe0b7e7d70b..7fe272befaec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=amxb-inspect-git
-pkgver=v0.1.3.r0.g649600c
+pkgver=1.2.0.r0.gc244343
pkgrel=1
pkgdesc="Ambiorix Backend inspector/validation tool"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxb'
)
makedepends=(
+ 'git'
)
provides=(
'amxb-inspect'
@@ -19,14 +20,14 @@ conflicts=(
'amxb-inspect'
)
-gitbranch="master"
+gitbranch="main"
source=("${pkgname}::git+https://gitlab.com/soft.at.home/ambiorix/applications/amxb-inspect.git#branch=${gitbranch}")
md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -36,5 +37,6 @@ build() {
package() {
cd "${pkgname}"
- make DEST="${pkgdir}/" install
+ make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}