summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 24 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd640daad359..f9d1ee06b564 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,45 @@
# Maintainer : Immae <ismael.bouya@normalesup.org>
# Contributor : Martin Wimpress <code@flexion.org>
# Contributor : Jingbei Li <i@jingbei.li>
-
pkgname=anaconda2
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Completely free enterprise-ready Python distribution for large-scale data processing, predictive analytics, and scientific computing."
-arch=('x86' 'x86_64')
+arch=('x86_64')
url="https://store.continuum.io/cshop/anaconda/"
license=("custom")
makedepends=('patch')
source=("http://repo.continuum.io/archive/Anaconda2-${pkgver}-Linux-x86_64.sh"
- "$pkgname.install")
+"$pkgname.install")
options=(!strip libtool staticlibs)
sha256sums=('58a7117f89c40275114bf7e824a613a963da2b0fe63f2ec3c1175fea785b468e'
- 'c491735df1753335c6aa5b3b71bd936ccb4ff5622fedbf22d1d6d9da5bd45fbc')
+'c491735df1753335c6aa5b3b71bd936ccb4ff5622fedbf22d1d6d9da5bd45fbc')
install="$pkgname.install"
-_pkgarch=`uname -m`
-if [ "$CARCH" == "x86" ]; then
- _pkgarch="x86"
- sha256sums[0]='7764093f337a43e4962b12d01508c1a385f0f62c1ddc006b69af95ae763fc4c2'
- source[0]="http://repo.continuum.io/archive/Anaconda2-${pkgver}-Linux-x86.sh"
-fi
+prepare() {
+ cd ${srcdir}
+ msg2 "Patching Anaconda2-${pkgver}-Linux-x86_64.sh"
+ sed \
+ -e '/wc -c "\$THIS_PATH" | grep/s/!//' \
+ -e "/export FORCE/s|$|;sed \"/^def update_prefix/a\\\ new_prefix='/opt/$pkgname'\" -i pkgs/.install.py|" \
+ -i Anaconda2-${pkgver}-Linux-x86_64.sh
+}
package() {
- prefix=${pkgdir}/opt/${pkgname}
- LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
-
- msg2 "Installing anaconda to /opt/${pkgname}"
- bash ${srcdir}/Anaconda2-${pkgver}-Linux-${_pkgarch}.sh -b -p $prefix -f
+ prefix=${pkgdir}/opt/${pkgname}
+ LD_PRELOAD="/usr/lib/libfakeroot/libfakeroot.so"
- cd $prefix
+ msg2 "Installing anaconda to /opt/${pkgname}"
+ bash ${srcdir}/Anaconda2-${pkgver}-Linux-x86_64.sh -b -p $prefix -f
+ [ "$BREAK_EARLY" = 1 ] && exit 1
+ cd $prefix
- msg2 "Correcting permissions"
- chmod a+r -R $prefix/pkgs
+ msg2 "Correcting permissions"
+ chmod a+r -R pkgs
- msg2 "Stripping \$pkgdir"
- sed "s|${pkgdir}||g" -i $(grep "$pkgdir" . -rIl)
+ msg2 "Stripping \$pkgdir from default meta"
+ find conda-meta -name '*.json' -exec sed -e "s/${pkgdir//\//\\\/}//g" -i {} \;
- msg2 "Installing license"
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ msg2 "Installing license"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}