summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df4c7d814cb2..ffa804f87bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,14 @@
pkgname=ananicy-cpp-git
_pkgname=ananicy-cpp
-pkgver=1.0.0.rc5.r0.g3ae336b
+pkgver=1.0.0.rc5.r10.g0adc86c
pkgrel=1
pkgdesc="Ananicy Cpp is a full rewrite of Ananicy in C++, featuring lower CPU and RAM usage."
-source=("git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git")
-md5sums=('SKIP')
+source=(
+ "git+https://gitlab.com/ananicy-cpp/ananicy-cpp.git"
+ "git+https://gitlab.com/ananicy-cpp/stl-polyfills/std-format.git"
+)
+md5sums=('SKIP' 'SKIP')
arch=(x86_64 i386 armv7h)
depends=(fmt spdlog nlohmann-json systemd)
makedepends=(cmake git gcc)
@@ -22,6 +25,11 @@ pkgver() {
prepare() {
cd "$_pkgname"
+
+ git submodule init
+ git config submodule."external/std-format".url "${srcdir}/std-format"
+ git submodule update
+
mkdir -p build
cd build
@@ -35,13 +43,13 @@ prepare() {
build() {
cd "$_pkgname/build"
- cmake --build .
+ cmake --build . --target ananicy-cpp
}
package() {
cd "$_pkgname/build"
export DESTDIR="$pkgdir"
- cmake --install .
+ cmake --install . --component Runtime
install -m755 -d "$pkgdir/etc/ananicy.d"
}