summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95e00a12f2cc..1b78e7bb5a5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,12 @@ source android-env.sh ${_android_arch}
pkgname=android-${_android_arch}-ffmpeg
pkgver=4.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="Complete solution to record, convert and stream audio and video (android)"
arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
-depends=('apache-ant'
- 'android-ndk>=r18.b'
- "android-platform-$ANDROID_MINIMUM_PLATFORM"
- 'android-sdk-25.2.5'
- 'android-sdk-build-tools'
- 'android-sdk-platform-tools')
+depends=("android-${_android_arch}-libvorbis")
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-pkg-config' 'git' 'yasm')
source=("git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver}"
@@ -94,6 +89,15 @@ build() {
;;
esac
+ case "$_android_arch" in
+ aarch64)
+ ;;
+ *)
+ configue_opts+="
+ --enable-libvorbis"
+ ;;
+ esac
+
./configure ${configue_opts}
make $MAKEFLAGS
}