summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8949506371cd..59d3486e116b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_android_arch=aarch64
pkgname=android-$_android_arch-qt6-declarative
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -18,8 +18,20 @@ optdepends=('qt6-declarative: development tools')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtdeclarative-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('e6f64314b8d54d7b541f52827b4e795317b17c3b7f39ad5210b8dbf343b75bda')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Exclude-qmltime-when-cross-compiling.patch')
+sha256sums=('805394307479ebca9899996af8357037c4f1ff8b783162ade0c5a05cea7ee2d2'
+ 'ea1049987eb2c00190e794c678781e20c95cbff03eba698875de35258894a3a7')
+
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
build() {
source android-env ${_android_arch}