summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 4 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64d2ab3eb7d6..21a781783f5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
_android_arch=aarch64
pkgname=android-$_android_arch-qt6-svg
-_qtver=6.6.0
+_qtver=6.6.1
pkgver=${_qtver/-/}
-pkgrel=2
+pkgrel=1
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@@ -17,20 +17,8 @@ makedepends=('android-cmake' 'qt6-base' 'ninja' 'java-environment-openjdk>=11')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtsvg-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Fix-nullptr-dereference-with-invalid-SVG.patch')
-sha256sums=('33da25fef51102f564624a7ea3e57cb4a0a31b7b44783d1af5749ac36d3c72de'
- '83f59c72773071df6adca9c0f6f457a460bd63a4d2b85f1e0df9cabf6b1c55e9')
-
-prepare () {
- cd $_pkgfqn
-
- # apply patches; further descriptions can be found in patch files itself
- for patch in "$srcdir/"*.patch; do
- msg2 "Applying patch $patch"
- patch -p1 -i "$patch"
- done
-}
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('248deb56d26a463cf3162f530358ccf90cfb654bbf518bb35ddf81b205e09228')
build() {
source android-env ${_android_arch}