summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1a4e5d349e1..30d6aefb7f66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,23 +7,25 @@ _pkgname=strace
_pkg_arch=aarch64
pkgname=android-${_pkg_arch/_/-}-$_pkgname
pkgver=5.11
-pkgrel=1
+pkgrel=4
pkgdesc="A diagnostic, debugging and instructional userspace tracer (Android, $_pkg_arch)"
arch=(any)
url='https://strace.io/'
license=(BSD)
makedepends=(android-ndk)
options=(!buildflags !strip)
-source=(https://github.com/strace/strace/releases/download/v$pkgver/strace-$pkgver.tar.xz{,.asc})
-sha1sums=('1b7a533a45b9ca351d7a14702c044b917d11e979'
- 'SKIP')
+source=(https://github.com/strace/strace/releases/download/v$pkgver/strace-$pkgver.tar.xz{,.asc}
+ issue174.patch)
+sha256sums=('ffe340b10c145a0f85734271e9cce56457d23f21a7ea5931ab32f8cf4e793879'
+ 'SKIP'
+ '169dc3b66e2a2ec364dc30e792b1d8e9fb9357ad3797ba84d88f478b63f393d0')
validpgpkeys=('296D6F29A020808E8717A8842DB5BD89A340AEB7') # Dmitry V. Levin <ldv@altlinux.org>
prepare() {
cd $_pkgname-$pkgver
- # Upstream bundled Linux uapi header breaks building
# https://github.com/strace/strace/issues/174
- rm -vf bundled/linux/include/uapi/linux/socket.h
+ patch -Np1 -i ../issue174.patch
+ autoreconf -ifv
}
build() {