summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04b78b6efd1c..321440ae2885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,32 @@
pkgname=android-ndk
pkgver=r20
-pkgrel=1
+pkgrel=3
pkgdesc='Android C/C++ developer kit'
arch=('x86_64')
url='https://developer.android.com/ndk/'
license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
-backup=('etc/profile.d/android-ndk.sh')
+backup=("etc/profile.d/$pkgname.sh")
install="$pkgname.install"
replaces=('android-ndk64')
depends=('glibc')
-source=('android-ndk.sh')
+optdepends=(
+ 'ncurses5-compat-libs: for using gdb'
+ 'python2: various helper scripts'
+ 'python: various helper scripts'
+)
+source=("$pkgname.sh")
source_x86_64=("https://dl.google.com/android/repository/$pkgname-${pkgver/./}-linux-x86_64.zip")
+# SHA1 sums is kept to follow upstream releases https://github.com/android-ndk/ndk/issues/673
sha1sums=('2479a8d74428eb651ad2b9772ad655d7a90af410')
sha1sums_x86_64=('8665fc84a1b1f0d6ab3b5fdd1e30200cc7b9adff')
+sha256sums=('2068618bc3e99149310f544be5d639ae183dc767d5a7157a07d8e024417b6017')
+sha256sums_x86_64=('57435158f109162f41f2f43d5563d2164e4d5d0364783a9a6fab3ef12cb06ce0')
package() {
install -Ddm755 "$pkgdir/opt"
mv "$pkgname-${pkgver/./}" "$pkgdir/opt/$pkgname"
- install -Dm755 android-ndk.sh "$pkgdir/etc/profile.d/android-ndk.sh"
+ install -Dm644 $pkgname.sh -t "$pkgdir/etc/profile.d/"
}
-
-# vim: ts=2 sw=2 et: