summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88f985eaff70..786858eb9903 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,7 @@
# Contributor: Jiaxi Hu <sftrytry _AT_ gmail _DOT_ com>
# Contributor: jimmy00784 <jimmy00784@gmail.com>
# Contributor: Ricardo (XenGi) Band <email@ricardo.band>
+# Contributor: Martchus <martchus@gmx.net>
# Useful link to keep track of latest API changes:
#
@@ -13,13 +14,22 @@ android_arch=x86
# Minimum Android platform based on:
#
# https://developer.android.com/about/dashboards/
-ANDROID_MINIMUM_PLATFORM=21
-export ANDROID_MINIMUM_PLATFORM
+if [ -z "${ANDROID_MINIMUM_PLATFORM}" ]; then
+ export ANDROID_MINIMUM_PLATFORM=21
+fi
+
+if [ -z "${ANDROID_NDK_ROOT}" ]; then
+ export ANDROID_NDK_ROOT=/opt/android-ndk
+fi
+
+if [ -z "${ANDROID_SDK_ROOT}" ]; then
+ export ANDROID_SDK_ROOT=/opt/android-sdk
+fi
_pkgname=android-qt5
pkgname=${_pkgname}-${android_arch}
pkgver=5.11.2
-pkgrel=1
+pkgrel=2
pkgdesc="Qt 5 for Android"
arch=('x86_64')
url='https://www.qt.io'
@@ -64,15 +74,18 @@ options=('!strip'
'!emptydirs')
_pkgfqn="qt-everywhere-src-${pkgver}"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
- "0001-Fix-clang-build.patch")
+ "0001-Fix-clang-build.patch"
+ "0002-Disable-mapbox.patch")
md5sums=('152a8ade9c11fe33ff5bc95310a1bb64'
- '511eafcabe9e0c6210f1dc5e26daa5c8')
+ '511eafcabe9e0c6210f1dc5e26daa5c8'
+ '20d8bdd24102e9011b561b7361394728')
prepare() {
cd ${_pkgfqn}
# Platform specific patches.
patch -Np1 -i "../0001-Fix-clang-build.patch"
+ patch -Np1 -i "../0002-Disable-mapbox.patch"
}
get_last() {
@@ -92,9 +105,6 @@ build() {
unset QTDIR
unset CARCH
- export ANDROID_NDK_ROOT=/opt/android-ndk
- export ANDROID_SDK_ROOT=/opt/android-sdk
-
if [ -z "${ANDROID_BUILD_TOOLS_REVISION}" ]; then
export ANDROID_BUILD_TOOLS_REVISION=$(get_last ${ANDROID_SDK_ROOT}/build-tools)
fi
@@ -133,11 +143,6 @@ build() {
-android-arch ${android_arch}
-android-ndk-platform ${ANDROID_NDK_PLATFORM}"
- # qtlocation needs mapbox-gl-native, and mapbox-gl-native needs C++17 and
- # higher so disable it for a while.
- configue_opts+="
- -skip qtlocation"
-
# Platform specific patches
case "$android_arch" in
x86*)
@@ -178,9 +183,9 @@ package() {
;;
esac
- export ANDROID_NDK_ROOT=/opt/android-ndk
STRIP=${ANDROID_NDK_ROOT}/toolchains/${toolchain}/prebuilt/linux-x86_64/${stripFolder}/bin/strip
find ${pkgdir}/opt/${_pkgname}/${android_arch}/lib -name 'lib*.so' -exec ${STRIP} {} \;
find ${pkgdir}/opt/${_pkgname}/${android_arch}/lib \( -name 'lib*.a' ! -name 'libQt5Bootstrap.a' ! -name 'libQt5QmlDevTools.a' \) -exec ${STRIP} {} \;
find ${pkgdir}/opt/${_pkgname}/${android_arch}/plugins -name 'lib*.so' -exec ${STRIP} {} \;
+ sed -i '/QMAKE_PRL_BUILD_DIR/d' ${pkgdir}/opt/${_pkgname}/${android_arch}/lib/lib*.prl
}