summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95cd46e2d217..5ef5253e9f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,9 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
_android_arch=x86-64
-source android-env ${_android_arch}
pkgname=android-${_android_arch}-libwebp
-pkgver=1.0.3
+pkgver=1.3.2
pkgrel=1
pkgdesc="WebP library and conversion tools (android)"
arch=('any')
@@ -15,18 +14,22 @@ depends=("android-${_android_arch}-libjpeg-turbo"
"android-${_android_arch}-libpng"
"android-${_android_arch}-libtiff"
"android-${_android_arch}-giflib")
+groups=(android-libwebp)
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-configure')
source=("https://github.com/webmproject/libwebp/archive/v${pkgver}.tar.gz")
-sha256sums=('082d114bcb18a0e2aafc3148d43367c39304f86bf18ba0b2e766447e111a4a91')
+md5sums=('827d510b73c73fca3343140556dd2943')
prepare() {
cd "$srcdir/libwebp-${pkgver}"
+ source android-env ${_android_arch}
+
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd "$srcdir/libwebp-${pkgver}"
+ source android-env ${_android_arch}
unset LDFLAGS
android-${_android_arch}-configure \
@@ -39,6 +42,7 @@ build() {
package() {
cd "$srcdir/libwebp-${pkgver}"
+ source android-env ${_android_arch}
make DESTDIR="$pkgdir" install
rm -r "${pkgdir}"/${ANDROID_PREFIX_BIN}