summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 903511ccd090..40e79ed61e65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,19 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-x265
pkgver=3.3
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc='Open Source H265/HEVC video encoder (android)'
license=('GPL')
-url='https://bitbucket.org/multicoreware/x265'
+url='https://github.com/videolan/x265'
depends=('android-ndk')
options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-cmake' 'nasm')
-source=("https://bitbucket.org/multicoreware/x265/downloads/x265_${pkgver}.tar.gz")
-sha256sums=('f26e148ed1f4dfb33fd1eb3ff5e60e08078d1b2017e88bcbb045b3fb58300b9c')
+source=("https://github.com/videolan/x265/archive/${pkgver}.tar.gz")
+sha256sums=('ca25a38772fc6b49e5f1aa88733bc1dc92da7dc18f02a85cc3e99d76ba85b0a9')
build() {
- cd "${srcdir}"/x265_${pkgver}
+ cd "${srcdir}"/x265-${pkgver}
source android-env ${_android_arch}
unset LDFLAGS CPPFLAGS
@@ -75,7 +75,7 @@ build() {
}
package() {
- cd "${srcdir}"/x265_${pkgver}/build-8
+ cd "${srcdir}"/x265-${pkgver}/build-8
source android-env ${_android_arch}
make DESTDIR="$pkgdir" install