summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dc102d923e3..84a5f01d02e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
_android_arch=x86
-source android-env ${_android_arch}
pkgname=android-${_android_arch}-libvorbis
pkgver=1.3.6
-pkgrel=3
+pkgrel=4
pkgdesc="Vorbis codec library (android)"
arch=('any')
url="http://xiph.org"
@@ -20,12 +19,14 @@ sha256sums=('6ed40e0241089a42c48604dc00e362beee00036af2d8b3f46338031c9e0351cb'
prepare() {
cd "${srcdir}"/libvorbis-${pkgver}
+ source android-env ${_android_arch}
patch -Np1 -i "../configure.patch"
}
build() {
cd "${srcdir}"/libvorbis-${pkgver}
+ source android-env ${_android_arch}
android-${_android_arch}-configure
make $MAKEFLAGS
@@ -33,6 +34,7 @@ build() {
package() {
cd "${srcdir}"/libvorbis-${pkgver}
+ source android-env ${_android_arch}
make DESTDIR="$pkgdir" install
rm -r "${pkgdir}"/${ANDROID_PREFIX_SHARE}