summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91934139f76a..d3516b168fd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,12 @@ _android_arch=x86
_android_platform_arch=arch-x86
_pkgname=openssl
_ver=1.1.1i
+_patchname=15-android_conf
pkgname=android-$_pkg_arch-$_pkgname
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
-pkgrel=1
+pkgrel=2
pkgdesc="The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (Android, $_pkg_arch)"
arch=('any')
url='https://www.openssl.org'
@@ -20,16 +21,23 @@ depends=('android-sdk' 'android-ndk')
makedepends=('android-environment' 'android-sdk-build-tools')
conflicts=("android-$_pkgname-$_android_arch")
replaces=("android-$_pkgname-$_android_arch")
-source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc})
+source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
+ "${_patchname}.patch")
sha256sums=('e8be6a35fe41d10603c3cc635e93289ed00bf34b79671a3a4de64fcee00d5242'
- 'SKIP')
+ 'SKIP'
+ '8ed3b78e8d6e5766595ae5ad6503cf0d21de4300d90aae556c7786f07ed9fdfb')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
'7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
build() {
- cd "$srcdir/$_pkgname-$_ver"
+ cd "${srcdir}/${_pkgname}-${_ver}"
source android-env ${_pkg_arch}
- export PATH="$ANDROID_TOOLCHAIN/bin:$PATH"
+ export PATH="${ANDROID_TOOLCHAIN}/bin:${PATH}"
+
+ # Configure configuration script for android that shipped with openssl
+ # 1.1.1i does not account for the removal of the $ndk/platforms directory in
+ # android-ndk r22.
+ patch -Np1 < "${srcdir}/${_patchname}.patch"
# don't use -mandroid flag (Clang as provided by the NDK does not like it)
sed -i -e 's/-mandroid//' Configurations/15-android.conf
@@ -41,7 +49,7 @@ build() {
-Wl,--no-allow-shlib-undefined \
-Wl,--no-undefined \
no-stdio \
- no-ui \
+ no-ui-console \
threads \
shared \
android-${_android_platform_arch##arch-}