summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32e0575d3660..c472c5808ea8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Hu3rror <hu3rror@protonmail.com>
pkgname=animationgarden-bin
-pkgver=2.0.0
+pkgver=2.0.1
pkgrel=1
pkgdesc="Desktop application for Animation Garden."
arch=('x86_64')
url="https://github.com/Him188/animation-garden"
license=('GPL')
depends=('expat' 'util-linux-libs' 'xdg-utils' 'zlib')
-source=("https://github.com/Him188/animation-garden/releases/download/v2.0.0/AnimationGarden-2.0.0-debian-amd64.deb")
-sha512sums=('7562a5bc477a988c5bdf74dfc4c1c767814f8e6ed35faf7a39b15842923e7a48a4548ade5379ec73aa8d9cdf1880ca09ec17201379f945920872a04176958853')
+source=("https://github.com/Him188/animation-garden/releases/download/v$pkgver/AnimationGarden-$pkgver-debian-amd64.deb")
+sha512sums=('1ffcb2bde3ce49180956a71c31c47fe088415833ea49d55a389db5c4b1cd31838196c38a2b34ddbfa007bb0fe79fd9f7d6fab0f4528a31c0d062fcf65f2f4509')
provides=(animationgarden-bin)
conflicts=(animationgarden-bin-dev)
-package(){
+package() {
cd "${srcdir}"
# Extract package dataj
tar -xJ -f data.tar.xz -C "${pkgdir}"
install -dm755 "${pkgdir}"/usr/bin
ln -s /opt/animationgarden/bin/AnimationGarden "${pkgdir}"/usr/bin/AnimationGarden
install -Dm644 "${pkgdir}"/opt/animationgarden/share/doc/copyright "${pkgdir}"/usr/share/licenses/$pkgname/COPYRIGHT
- sed -i 's|^Exec=/opt/animationgarden/bin/AnimationGarden|Exec=AnimationGarden|g' "${pkgdir}"/opt/animationgarden/lib/animationgarden-AnimationGarden.desktop
- sed -i 's|^Icon=/opt/animationgarden/lib/AnimationGarden|Icon=/usr/share/icons/AnimationGarden|g' "${pkgdir}"/opt/animationgarden/lib/animationgarden-AnimationGarden.desktop
+ sed -i 's|^Exec=/opt/animationgarden/bin/AnimationGarden|Exec=AnimationGarden|g' "${pkgdir}"/opt/animationgarden/lib/animationgarden-AnimationGarden.desktop
+ sed -i 's|^Icon=/opt/animationgarden/lib/AnimationGarden|Icon=/usr/share/icons/AnimationGarden|g' "${pkgdir}"/opt/animationgarden/lib/animationgarden-AnimationGarden.desktop
install -Dm644 "${pkgdir}/opt/animationgarden/lib/animationgarden-AnimationGarden.desktop" "${pkgdir}/usr/share/applications/animationgarden-AnimationGarden.desktop"
install -Dm644 "${pkgdir}/opt/animationgarden/lib/AnimationGarden.png" "${pkgdir}/usr/share/icons/AnimationGarden.png"
}