summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8be4c2d9344..9d99d6ed27e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Maintainer: Kuklin István <kuklinistvan@zoho.com>
pkgname=anki-official-binary-bundle
pkgver=2.1.9
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
arch=('x86_64')
@@ -25,14 +25,16 @@ options=()
install=
changelog=
topdirname="anki-$pkgver-linux-amd64"
-source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch")
+source=("https://apps.ankiweb.net/downloads/current/${topdirname}.tar.bz2" "remove_xdg_cmds_from_makefile.patch" "prefix-fix.patch")
noextract=()
-md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f')
+md5sums=('8cc5bb80efc5dac2e9dc9ee802924e24' 'a7e473f132a4fecd9cb77ac9c8530f5f'
+ '5968099e737668ad7134edfd8bc6f323')
validpgpkeys=()
prepare() {
cd "$srcdir"
patch -p0 -i remove_xdg_cmds_from_makefile.patch
+ patch -p0 -i prefix-fix.patch
}
build() {
@@ -40,12 +42,7 @@ build() {
make
}
-# check() {
-# cd "$topdirname"
-# make -k check
-# }
-
package() {
cd "$topdirname"
- make PREFIX="$pkgdir/usr" install
+ make PREFIX="$pkgdir/usr/" install
}