summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2da9bc88ae09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+
+pkgname=ansible-container
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="Ansible Container is a tool to build and orchestrate containers using only Ansible playbooks."
+arch=('any')
+url="https://github.com/ansible/ansible-container"
+license=('GPL')
+depends=('python-structlog' 'python-six' 'python-jinja' 'python-ruamel-yaml' 'python-pip' 'python-requests')
+optdepends=(
+ 'python-docker: building docker containers'
+ )
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ansible/ansible-container/archive/release-$pkgver.tar.gz")
+md5sums=('9258f9cdb75303fd4f520ab223a357ac')
+
+package() {
+ cd "$pkgname-release-$pkgver"
+ python setup.py install --root="${pkgdir}"
+}