summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ece5275350f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jah Way <jahway603 at protonmail dot com>
+
+pkgname=ansiwave-bin
+_pkg=ansiwave
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="The FLARE team's open-source tool to identify capabilities in executable files"
+url="https://github.com/ansiwave/ansiwave"
+arch=('x86_64')
+license=('unlicense')
+source=("$url/releases/download/$pkgver-linux/ansiwave"
+ "https://raw.githubusercontent.com/ansiwave/ansiwave/master/UNLICENSE")
+sha512sums=('1549b775bad99f4b0cae62402b029906ad02a798abee47da0030ccce095d05f0f3726c5b0e92a53c71f759a5d56587c5706a95a5b7c437c20a99a48aaa360606'
+ 'aa647966e7fb62ffcd7bfc1e56a8ebe38e8384a36c14e07fec4ccf3be91ffa1b3bbd9798901fa7956056c26d124f067582366bdb9581db1f742291c86e64e39d')
+
+package() {
+ install -Dm755 "${srcdir}/ansiwave" "$pkgdir/opt/${_pkg}/ansiwave"
+ install -Dm644 "${srcdir}/UNLICENSE" "$pkgdir/usr/share/licenses/${_pkg}/UNLICENSE"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -s /opt/${_pkg}/ansiwave "${pkgdir}/usr/bin"
+}