summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ea350e8bb41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=ant-dracula-theme-git
+_pkgname=Ant-Dracula
+pkgver=48.6ea5b16
+pkgrel=1
+pkgdesc="Dracula variant of the Ant theme"
+arch=("any")
+url="https://github.com/EliverLara/${_pkgname}"
+license=('GPL')
+optdepends=('ttf-roboto: primary font face defined'
+ 'ttf-ubuntu-font-family: secondary font face defined'
+ 'cantarell-fonts: tertiary font face defined')
+source=("${_pkgname}::git+https://github.com/EliverLara/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ export THEME_FONT_FACE="${THEME_FONT_FACE:-Roboto}"
+ export THEME_FONT_SIZE="${THEME_FONT_SIZE:-10}"
+
+ msg2 "To customize the font size for gnome-shell, build this pacakge"
+ msg2 "with the variables below set to the desired font family and size"
+ msg2 "- THEME_FONT_FACE (default font family is Roboto)"
+ msg2 "- THEME_FONT_SIZE (default font point size is 10)"
+ msg2 ""
+ msg2 "Continuing build in 5 seconds..."; sleep 5
+ msg2 "Setting gnome-shell font face to ${THEME_FONT_FACE}"
+ msg2 "Setting gnome-shell font size to ${THEME_FONT_SIZE}"
+
+ if [ "${THEME_FONT_FACE}" != "Roboto" ]; then
+ sed -i -re "s/font-family: (.*);/font-family: ${THEME_FONT_FACE}, \1;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+
+ if [ "${THEME_FONT_SIZE}" != "10" ]; then
+ sed -i -re "s/font-size: (.*);/font-size: ${THEME_FONT_SIZE}pt;/" \
+ "${srcdir}/${_pkgname}/gnome-shell/gnome-shell.css"
+ fi
+
+ msg2 "Rendering assets, please wait"
+ pushd gtk-2.0
+ while read $line; do echo -n "."; done < \
+ <(./render-assets.sh; ); echo
+ popd
+
+ pushd gtk-3.20/assets
+ while read $line; do echo -n "."; done < \
+ <(./render-gtk3-assets.py; ./render-gtk3-assets-hidpi.py); echo
+ popd
+ msg2 "Done!"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ mkdir -p "${pkgdir}/usr/share/themes/${_pkgname}"
+ cp -a "${srcdir}/${_pkgname}/"* "${pkgdir}/usr/share/themes/${_pkgname}/"
+}