summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa2400b9e82b..7c26c735356d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer of this PKGBUILD file: Martino Pilia <martino.pilia@gmail.com>
pkgname='ants'
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Advanced Normalization Tools (ANTs) computes high-dimensional mappings to capture the statistics of brain structure and function'
arch=('i686' 'x86_64')
url='http://www.picsl.upenn.edu/ANTS/'
@@ -18,6 +18,10 @@ prepare() {
_builddir="${srcdir}/ANTs-${pkgver}/build"
mkdir -p "$_builddir" || :
+ # include this patch: https://github.com/ANTsX/ANTs/commit/89af9b2694715bf8204993e032fa132f80cf37bd
+ sed -i 's/void GetPriorLabelParameterMap/LabelParameterMapType GetPriorLabelParameterMap/' \
+ "${srcdir}/ANTs-${pkgver}/ImageSegmentation/antsAtroposSegmentationImageFilter.h"
+
cd "$_builddir"
cmake \