summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 4 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67981f57408f..385abca70938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.2288.g282c8b1
+pkgver=0.0.2460.g8e7f329
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
url="https://github.com/anura-engine/anura"
license=('GPL')
-depends=(libgl mesa glew glm sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-libs)
+depends=(libgl mesa glew cairo sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-libs)
optdepends=('frogatto-git: the default game module'
'box2d: box2d physics')
makedepends=(git boost)
source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
- anura.sh
- 0001-Change-Makefile-to-enable-ccache-to-work.patch)
+ anura.sh)
md5sums=('SKIP'
- '15f4c03c2404bcfd7618b8f9e0c850ba'
- '63fee48f8260aa1e51f7d4ab9bdb925f')
+ '15f4c03c2404bcfd7618b8f9e0c850ba')
install=anura.install
_gitname=anura
@@ -32,15 +30,6 @@ pkgver() {
fi
}
-prepare() {
- cd $_gitname
-
- git apply ../0001-Change-Makefile-to-enable-ccache-to-work.patch
-
- # use system boost headers
- rm -r external/include/boost
-}
-
build() {
cd $_gitname