aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bae4074104a..b2b5622ac4b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=anycable-go
pkgdesc="AnyCable WebSocket Server written in Go"
-pkgver=1.2.0
+pkgver=1.2.1
pkgrel=1
arch=('i686' 'x86_64')
url="http://anycable.io"
license=('MIT')
makedepends=('go' 'rsync')
source=("https://github.com/anycable/anycable-go/archive/v${pkgver}.tar.gz")
-sha256sums=('d8d411e078f0e3de754623fe4d68025d60c8a9fcd31a29972d8c2f72d2a8d541')
+sha256sums=('b14a2e0a453c121c4d7bb60189e360751c6e6e2d5f3f7ccb8e17dfa1b51b35f7')
# See https://wiki.archlinux.org/index.php/Go_package_guidelines
prepare(){
@@ -24,7 +24,7 @@ build() {
export GOPATH="$srcdir"/gopath
export CGO_ENABLED=0
export GO111MODULE=on
- export GOFLAGS=-mod=vendor
+ export GOFLAGS=-mod=mod
go build \
-ldflags "-s -w -X main.version=$pkgver" \
-gcflags "all=-trimpath=$GOPATH" \