summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 083768595ae4..df304ed111e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jari Ahola <aphototool@ahola.me>
pkgname=aphototoollibre
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.0.2
+pkgrel=1
pkgdesc="Photo editor for Linux"
arch=('x86_64')
url="https://www.ahola.me/aphototoollibre.html"
@@ -10,7 +10,7 @@ depends=('qt5-base>=5.15.2' 'hicolor-icon-theme')
makedepends=()
source=("$pkgname-$pkgver-$pkgrel-src.tar.gz::https://github.com/aphototool/A-Photo-Tool-Libre/archive/refs/tags/v$pkgver-$pkgrel.tar.gz"
"$pkgname-$pkgver-$pkgrel-src.tar.gz.asc::https://github.com/aphototool/A-Photo-Tool-Libre/releases/download/v$pkgver-$pkgrel/v$pkgver-$pkgrel.tar.gz.asc")
-sha256sums=('42f22e1c294c89704cd564365b2519981ef02f3c9b95f176c6d243fd6c420d98' 'SKIP')
+sha256sums=('2197498de0059392a62621f7c7e696d0d54bb57779b82e442d6ba89849e12c73' 'SKIP')
validpgpkeys=('A970F7E40CB64F0D5B9FC516AFE56C2DF614820C')
build() {
@@ -21,12 +21,10 @@ build() {
package() {
cd "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel"
- mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/applications"
- mkdir -p "$pkgdir/usr/share/icons/hicolor/scalable/apps"
- mkdir -p "$pkgdir/usr/share/metainfo"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/bin/APhotoToolLibre" "$pkgdir/usr/bin/"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/desktop/me.ahola.aphototoollibre.desktop" "$pkgdir/usr/share/applications/"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/desktop/me.ahola.APhotoToolLibre.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/"
- cp "$srcdir/A-Photo-Tool-Libre-$pkgver-$pkgrel/desktop/me.ahola.aphototoollibre.metainfo.xml" "$pkgdir/usr/share/metainfo/"
+ install -Dm755 "bin/aphototoollibre" "$pkgdir/usr/bin/aphototoollibre"
+ install -Dm644 "debian/aphototoollibre.1.gz" "$pkgdir/usr/share/man/man1/aphototoollibre.1.gz"
+ install -Dm644 "desktop/me.ahola.aphototoollibre.desktop" "$pkgdir/usr/share/applications/me.ahola.aphototoollibre.desktop"
+ install -Dm644 "desktop/me.ahola.aphototoollibre.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/me.ahola.aphototoollibre.svg"
+ install -Dm644 "desktop/me.ahola.aphototoollibre.metainfo.xml" "$pkgdir/usr/share/metainfo/me.ahola.aphototoollibre.metainfo.xml"
}
+