summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 757af822822e..dbb8e7a76759 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
pkgname=apio
_name=apio
-pkgver=0.8.1
+pkgver=0.8.4
pkgrel=1
pkgdesc="Experimental micro-ecosystem for open FPGAs"
arch=('any')
url="https://pypi.org/project/apio/"
license=('GPL')
-depends=('python-click' 'python-pyserial' 'python-semantic-version'
- 'python-colorama' 'python-requests' 'sudo'
- 'python-wheel' 'scons' 'python-setuptools')
-makedepends=('python-build' 'python-flit' 'python-install')
+depends=(
+ 'python-click'
+ 'python-colorama'
+ 'python-pyserial'
+ 'python-requests'
+ 'python-semantic-version'
+ 'python-setuptools'
+ 'python-wheel'
+ 'scons'
+)
+makedepends=('python-build' 'python-flit-core' 'python-installer' 'python-wheel')
checkdepends=('python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('73c24f6fe8174dac50c0a29084c20f7fe958c5af6f37d0dc49f9f495f5746766')
+sha256sums=('baa8edbdf933ff098178418214b19dfce0cad233ecbe5fc73b896bb7434b5d8f')
build() {
cd "${_name}-$pkgver"
@@ -24,8 +31,8 @@ check() {
cd "${_name}-$pkgver"
# We need a venv since apio.commands.upgrade requests the installed apio package version
- python -m venv --system-site-packages test-venv
- ./test-venv/bin/python -m install dist/*.whl
+ python -m venv --system-site-packages --clear test-venv
+ ./test-venv/bin/python -m installer dist/*.whl
./test-venv/bin/python -m pytest -v -c /dev/null test --offline
}
@@ -33,7 +40,5 @@ check() {
package() {
cd "${_name}-$pkgver"
- python -m install --optimize=1 --destdir="$pkgdir" dist/*.whl
-
- chmod +x $pkgdir/usr/bin/apio
+ python -m installer --destdir="$pkgdir" dist/*.whl
}