summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c31ea945175
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Daniel Landau <aur@landau.fi>
+
+_pkgname=AppCSXCAD
+pkgname=appcsxcad
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Minimal GUI Application using the QCSXCAD library."
+arch=("x86_64")
+url="https://github.com/thliebig/$_pkgname"
+license=("GPL3")
+depends=("csxcad-git" "hdf5" "vtk" "qt5-base")
+makedepends=("cmake")
+optdepends=()
+source=("https://github.com/thliebig/$_pkgname/archive/v$pkgver.tar.gz"
+)
+md5sums=('97d4cbc9c116579c8bfd5bde00e80627')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
+ cmake ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/build"
+ make install DESTDIR="$pkgdir"
+}