summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 3 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2dd0469fe6c2..c7191b22c53c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,11 @@ pkgdesc='GNU/Linux packaging solution using the AppImage format'
url=https://github.com/AppImageCrafters/appimage-builder
arch=(x86_64)
license=(MIT)
+conflicts=('appimage-builder')
+provides=('appimage-builder')
depends=("binutils" "desktop-file-utils" "fakeroot" "gdk-pixbuf2" "patchelf" "python-pip" "python-setuptools" "squashfs-tools" "strace" "wget" "zsync")
options=(!strip)
+install='appimage-builder.install'
_tag="Continuous"
_appimage="appimage-builder-1.1.1.dev32+g2709a3b-x86_64.AppImage"
_desktop="org.appimage-crafters.appimage-builder.desktop"
@@ -23,19 +26,6 @@ package() {
"${srcdir}/${_appimage}" \
"${pkgdir}/opt/${_pkgname}/${_pkgname}.AppImage"
- # Skipping desktop & icon since those don't make sense
- # for a tool like this
-
- # Desktop file
- # install -Dm644 \
- # "${srcdir}/squashfs-root/${_desktop}" \
- # "${pkgdir}/usr/share/applications/${_desktop}"
-
- # Icon images
- # install -dm755 "${pkgdir}/usr/share/"
- # cp -a \
- # "${srcdir}/squashfs-root/usr/share/icons" \
- # "${pkgdir}/usr/share/"
# Symlink executable
install -dm755 "${pkgdir}/usr/bin"