summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14557b10b809..f6ee7850a27f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,19 @@
# Contributor: Joseph R. Prostko <joe dot prostko at gmail dot com>
pkgname=aptly
-pkgver=1.4.0
-pkgrel=4
+pkgver=1.5.0
+pkgrel=1
pkgdesc="A Swiss Army knife for Debian repository management."
url="https://www.aptly.info"
license=('MIT')
options=('!strip')
arch=('i686' 'x86_64')
-_commit="f9d08e1377970d2b13410da3d1d452b935041a4e"
-_org="aptly-dev"
-_repo="aptly"
makedepends=('go')
-source=("https://github.com/${_org}/${_repo}/archive/${_commit}.tar.gz")
+source=("https://github.com/aptly-dev/aptly/archive/refs/tags/v${pkgver}.tar.gz")
build() {
- cd "${srcdir}/${pkgname}-${_commit}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
export GO11MODULE=on
export CGO_LDFLAGS="${LDFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
@@ -28,14 +26,21 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${_commit}"
- install -Dm755 "${pkgname}_build" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -Dm755 "${pkgname}_build" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}.service" \
+ -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm644 completion.d/aptly "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
- install -Dm644 completion.d/_aptly "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
- install -Dm644 man/aptly.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -Dm644 completion.d/aptly \
+ "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ install -Dm644 completion.d/_aptly \
+ "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+ install -Dm644 man/aptly.1 \
+ "${pkgdir}/usr/share/man/man1/${pkgname}.1"
}
-sha256sums=('7904a9422d93d79839e315931dd7061b41a7d8b414612c6a9cfc1b0609fa4d45')
+sha256sums=('07e18ce606feb8c86a1f79f7f5dd724079ac27196faa61a2cefa5b599bbb5bb1')