summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 21 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e3515105e07..59a8b466f1f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,40 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: tarball <bootctl@gmail.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
+# Contributor: fortea
pkgname=apx
pkgver=1.8.2
-pkgrel=1
-pkgdesc='Wrapper around multiple package managers to install packages and run commands inside a managed container'
+pkgrel=2
+pkgdesc='Package manager with support for multiple sources'
arch=(x86_64 aarch64)
url='https://github.com/Vanilla-OS/apx'
license=(GPL3)
depends=(
- distrobox
- glibc
+ distrobox
+ glibc
)
makedepends=(go)
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
b2sums=('615f1fce06db9e84f7ce1a421d60af5f4b3ad6de6faa2accd913b0520f46ce70285d959277bd90ec94febabd114279a1035535cfebc2c99ebf86271ace795cd1')
-prepare(){
- cd "${pkgname}-${pkgver}"
- mkdir -p build/
- sed -i 's|ubuntu|archlinux|g;s|apt|pacman|g;s|share/apx|bin|g' config/config.json
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ mkdir -p build/
+ sed -i 's|share/apx|bin|' config/config.json
}
build() {
- cd "${pkgname}-${pkgver}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -o build
-}
-
-check() {
- cd "${pkgname}-${pkgver}"
- go test
+ cd "${pkgname}-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
}
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "config/config.json" "${pkgdir}/etc/apx/config.json"
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "config/config.json" "${pkgdir}/etc/apx/config.json"
}