aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2dfe43e50e0..ab0d20f97846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=("i686" "x86_64")
url="https://www.arangodb.com/"
license=('APACHE')
depends=('openssl' 'systemd' 'curl' 'zlib')
-makedepends=("cmake" "python2")
+makedepends=("cmake" "gcc5" "python2")
options=()
install=arangodb.install
source=("https://www.arangodb.com/repositories/Source/ArangoDB-$pkgver.tar.bz2"
@@ -28,6 +28,9 @@ build() {
ln -s -f /usr/bin/python2 python
export PATH="`pwd`:$PATH"
export LD="ld.gold"
+ # I'm not proud of this but currently it's the only way to compile this.
+ export CC="gcc-5"
+ export CXX="g++-5"
msg2 "Configuring ArangoDB."
cd $srcdir/ArangoDB-$pkgver