summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 877e2d5d62d4..ca4f5dc7a676 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=arcade-history-dat
-pkgver=155
+pkgver=186
pkgrel=1
-pkgdesc="Arcade History Database file to use for Emulators and Frontends with more than 36,000 entries!"
+pkgdesc="arcade history database file for emulators and frontends with more than 61000 entries"
arch=('any')
-url="http://www.arcade-history.com"
+url="https://www.arcade-history.com"
license=('custom')
-optdepends=('raine: for use in raine'
- 'qmc2: for use in qmc2')
+optdepends=('raine: for use in Raine'
+ 'qmc2: for use in QMC2'
+ 'sdlmame: for use in MAME')
source=("$url/dats/history$pkgver.7z")
-sha256sums=('05e8bec9c2f3f1747e4f5bf772a68289191c1e4d3ec9938d8d806056d8a4aab6')
+install=$pkgname.install
+sha256sums=('747c8934f416c5620babec5068acc23fb251c4915d270cee6d53436e5a009261')
package() {
install -Dm644 history.dat "$pkgdir"/usr/share/$pkgname/history.dat
@@ -20,8 +22,9 @@ package() {
ln -s /usr/share/$pkgname/history.dat "$pkgdir"/usr/share/raine/history.dat
# TODO: where to put it for other emulators/frontends?
+ # - MAME needs manual copy/symlink
# license
install -d "$pkgdir"/usr/share/licenses/$pkgname
- sed '/$end/,$d' history.dat > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ grep '^##' history.dat > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}