summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6416d244961c..877e2d5d62d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
pkgname=arcade-history-dat
-pkgver=154c
+pkgver=155
pkgrel=1
pkgdesc="Arcade History Database file to use for Emulators and Frontends with more than 36,000 entries!"
arch=('any')
url="http://www.arcade-history.com"
-license=('unknown')
+license=('custom')
optdepends=('raine: for use in raine'
'qmc2: for use in qmc2')
source=("$url/dats/history$pkgver.7z")
-sha256sums=('ab34365153f7aed3d7a910f7e6b6e91007833a1f01bc0c0b0c63eb50f9895673')
+sha256sums=('05e8bec9c2f3f1747e4f5bf772a68289191c1e4d3ec9938d8d806056d8a4aab6')
package() {
install -Dm644 history.dat "$pkgdir"/usr/share/$pkgname/history.dat
@@ -20,4 +20,8 @@ package() {
ln -s /usr/share/$pkgname/history.dat "$pkgdir"/usr/share/raine/history.dat
# TODO: where to put it for other emulators/frontends?
+
+ # license
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ sed '/$end/,$d' history.dat > "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}