summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..015d54a8e58f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: techfreak <techfreak@matrix.org>
+pkgname=arch-sec-check-git
+pkgver=1.1
+pkgrel=1
+pkgdesc="Compares your local installed packages with the arch linux security database"
+arch=(any)
+url="https://gitlab.com/techfreak/arch-sec-check"
+license=(GPL2)
+depends=(openssl)
+makedepends=(git cargo rust)
+optdepends=()
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ cargo build --release
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}