summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf3f9757438e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Tiago Koji Castro Shibata <tiago.shibata@gmail.com>
+pkgname=archc-git
+pkgver=2.4.1.r71.gf0b697c
+pkgrel=1
+pkgdesc='A powerful and modern open-source architecture description language'
+arch=('x86_64' 'i686')
+url='https://github.com/ArchC/ArchC'
+license=('GPL')
+depends=('bash')
+makedepends=('git' 'systemc')
+provides=('archc')
+conflicts=('archc')
+source=('git+https://github.com/ArchC/ArchC.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ArchC
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ArchC
+ ./autogen.sh
+ ./configure --prefix=$pkgdir/usr
+ make
+}
+
+package() {
+ cd ArchC
+ make install
+ # Move configuration files to /etc
+ mv $pkgdir/{usr/,}etc
+}