summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a6bcb39aff0..eaa4c9015854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,27 +3,31 @@
_name=archinstall
pkgname=archinstall-git
-pkgver='2.3.0.r2239.a4033a7'
+pkgver=2.4.0.dev0
pkgrel=1
pkgdesc="Just another guided/automated Arch Linux installer with a twist"
arch=('any')
url="https://github.com/archlinux/$_name"
-license=('GPL')
+license=('GPL3')
depends=('python')
makedepends=('python-setuptools' 'python-sphinx')
-provides=("python-$_name")
-conflicts=("python-$_name")
+provides=('python-archinstall')
+conflicts=('python-archinstall')
+replaces=('python-archinstall')
source=("git+https://github.com/archlinux/$_name.git")
sha256sums=('SKIP')
+
build() {
- cd "$srcdir/$_name"
- python setup.py build
- make man -C docs
+ cd "$_name"
+
+ python setup.py build
+ make man -C docs
}
package() {
- cd "$srcdir/$_name"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -vDm 644 docs/_build/man/$_name.1 -t "${pkgdir}/usr/share/man/man1/"
+ cd "$_name"
+
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -vDm 644 docs/_build/man/archinstall.1 -t "${pkgdir}/usr/share/man/man1/"
}