summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaa4c9015854..613f8d478392 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_name=archinstall
pkgname=archinstall-git
-pkgver=2.4.0.dev0
+pkgver=2.5.4.r1.g9f102a6
pkgrel=1
pkgdesc="Just another guided/automated Arch Linux installer with a twist"
arch=('any')
url="https://github.com/archlinux/$_name"
license=('GPL3')
depends=('python')
-makedepends=('python-setuptools' 'python-sphinx')
+makedepends=('git' 'python-setuptools' 'python-sphinx' 'python-build' 'python-installer' 'python-wheel')
provides=('python-archinstall')
conflicts=('python-archinstall')
replaces=('python-archinstall')
@@ -18,16 +18,31 @@ source=("git+https://github.com/archlinux/$_name.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$_name"
+ git describe --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_name
+
+ # Remove symlinks from the package source
+ # and move the actual files in before packaging.
+ rm -fv $_name/{examples,profiles}
+ mv -v examples profiles $_name/
+}
+
build() {
cd "$_name"
- python setup.py build
- make man -C docs
+ python -m build --wheel --no-isolation
+ PYTHONDONTWRITEBYTECODE=1 make man -C docs
}
package() {
cd "$_name"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ # We have previously added "--optimize=1", "--skip-build" and "--prefix=/usr" here.
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -vDm 644 docs/_build/man/archinstall.1 -t "${pkgdir}/usr/share/man/man1/"
}