summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03477c4952f9..5a6965a2dc30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,17 +10,17 @@ depends=("fuse" "libarchive")
makedepends=("automake" "autoconf" "make")
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+http://www.cybernoia.de/software/${pkgname%-git}/git")
+source=("${pkgname}::git+http://www.cybernoia.de/software/${pkgname%-git}/git")
sha512sums=('SKIP')
arch=("i686" "x86_64")
pkgver() {
- cd git
+ cd "${pkgname}"
git describe --tags --always | sed 's/-[[:digit:]]*-/./g'
}
build() {
- cd git
+ cd "${pkgname}"
aclocal
autoheader
automake --add-missing
@@ -30,7 +30,7 @@ build() {
}
package() {
- cd "git"
+ cd "${pkgname}"
install -Dm755 "${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
make PREFIX="/usr" DESTDIR="${pkgdir}/" install-man
mv "${pkgdir}/usr/local/share" "${pkgdir}/usr"