summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2c97bac8018..58d2bd80b647 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,7 @@ prepare(){
mkdir -p "$GOPATH"/src/github.com/arduino
ln -rTsf "${pkgname//-rc}-$pkgver" "$GOPATH"/src/github.com/arduino/arduino-builder
+ #cp -a "${pkgname//-rc}-$pkgver" "$GOPATH"/src/github.com/arduino/arduino-builder
cd "$GOPATH"/src/github.com/arduino/arduino-builder
export GO111MODULE=on
@@ -40,14 +41,16 @@ build() {
-asmflags "all=-trimpath=$GOPATH" \
-ldflags "-extldflags $LDFLAGS" \
-v .
-}
-check() {
- # Test will download ~1GB of testfiles
- cd "$GOPATH"/src/github.com/arduino/arduino-builder
- go test -v -timeout 60m .
+ chmod -R 744 "$GOPATH"
}
+#check() {
+# # Test will download ~1GB of testfiles
+# cd "$GOPATH"/src/github.com/arduino/arduino-builder
+# go test -v -timeout 60m .
+#}
+
package() {
# Fix platform.txt for arch arduino-ctags
#cd "${srcdir}/build/src/github.com/arduino/arduino-builder/hardware"