summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..599bc7daf1c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lars Hagström <lars@foldspace.nu>
+pkgname=arduino-keyboardio-boards-git
+pkgver=r23.0e49d47
+pkgrel=1
+pkgdesc="Arduino libraries for the Keyboard.io Model01"
+arch=('any')
+url="https://keyboard.io"
+license=('Unknown')
+depends=('arduino')
+source=("$pkgname"::"git+https://github.com/DonOregano/Arduino-Boards.git#branch=remove-flexible-arrays"
+ "adapt_to_arch.patch")
+sha1sums=('SKIP'
+ 'e78c9ccd9e4b552a3987bd16526cfb68549c17af')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ git submodule update --init
+ patch -Np1 -i "${srcdir}/adapt_to_arch.patch"
+}
+
+package() {
+ install -d $pkgdir/usr/share/arduino/hardware/keyboardio/avr/
+ cd $srcdir
+ cp -R $pkgname/* $pkgdir/usr/share/arduino/hardware/keyboardio/avr/
+}