summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fcaa4c3e60d..c0d800f02632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@
_target="arm-linux-gnueabihf"
pkgname="${_target}-gcc"
-pkgver=5.2.0
+pkgver=5.3.0
_pkgver=5
-_islver=0.14.1
+_islver=0.15
pkgrel=2
#_snapshot=5-20150623
pkgdesc="The GNU Compiler Collection (${_target})"
@@ -23,11 +23,9 @@ replaces=("${_target}-gcc-stage1" "${_target}-gcc-stage2")
provides=("${_target}-gcc-stage1=${pkgver}" "${_target}-gcc-stage2=${pkgver}")
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- pr66035.patch)
-md5sums=('a51bcfeb3da7dd4c623e27207ed43467'
- '118d1a379abf7606a3334c98a8411c79'
- '5b980076cd5fcbc3aff6014f306282dd')
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
+md5sums=('c9616fd448f980259c31de613e575719'
+ '8428efbbc6f6e2810ce5c1ba73ecf98c')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@@ -49,9 +47,6 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66035
- patch -p1 -i ${srcdir}/pr66035.patch
-
mkdir ${srcdir}/gcc-build
}
@@ -83,8 +78,7 @@ build() {
--enable-lto --enable-plugin --enable-install-libiberty \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \
- --enable-checking=release \
- --with-default-libstdcxx-abi=gcc4-compatible
+ --enable-checking=release
make
}