summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0d800f02632..38c0b2332c25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,23 +9,25 @@ pkgname="${_target}-gcc"
pkgver=5.3.0
_pkgver=5
_islver=0.15
-pkgrel=2
-#_snapshot=5-20150623
+pkgrel=5
+_snapshot=5-20160209
pkgdesc="The GNU Compiler Collection (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
url="http://gcc.gnu.org"
-depends=("${_target}-binutils>=2.25" "${_target}-glibc" 'libmpc' 'elfutils' 'zlib')
+depends=("${_target}-binutils>=2.26" "${_target}-glibc>=2.23" 'libmpc' 'elfutils' 'zlib')
checkdepends=('dejagnu' 'inetutils')
options=('!emptydirs' '!distcc' '!strip')
conflicts=("${_target}-gcc-stage1" "${_target}-gcc-stage2")
replaces=("${_target}-gcc-stage1" "${_target}-gcc-stage2")
provides=("${_target}-gcc-stage1=${pkgver}" "${_target}-gcc-stage2=${pkgver}")
-source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
- #ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('c9616fd448f980259c31de613e575719'
- '8428efbbc6f6e2810ce5c1ba73ecf98c')
+source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
+ Unlink-the-response-file.patch)
+md5sums=('499161c65b639aa5c12a14944582b7ec'
+ '8428efbbc6f6e2810ce5c1ba73ecf98c'
+ '1f4d4ef71004261376d26d5ba6a84499')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@@ -47,6 +49,9 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
+ # https://bugs.archlinux.org/task/47874 - commit f591a95d
+ patch -p1 -i $srcdir/Unlink-the-response-file.patch
+
mkdir ${srcdir}/gcc-build
}