summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90fa009e1a8f..6fffd1ea1203 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,11 @@
_target="arm-linux-gnueabihf"
pkgname=${_target}-gcc-stage1
-pkgver=5.2.0
+pkgver=5.3.0
_pkgver=5
-_islver=0.14.1
+_islver=0.15
pkgrel=2
+#_snapshot=5-20150623
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL' 'FDL' 'custom')
@@ -18,11 +19,9 @@ depends=("${_target}-binutils>=2.25" 'libmpc' 'zlib')
options=('!emptydirs' '!distcc' '!strip')
source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.bz2
#ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-${_snapshot}.tar.bz2
- http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2
- pr66035.patch)
-md5sums=('a51bcfeb3da7dd4c623e27207ed43467'
- '118d1a379abf7606a3334c98a8411c79'
- '5b980076cd5fcbc3aff6014f306282dd')
+ http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
+md5sums=('c9616fd448f980259c31de613e575719'
+ '8428efbbc6f6e2810ce5c1ba73ecf98c')
if [ -n "${_snapshot}" ]; then
_basedir=gcc-${_snapshot}
@@ -44,9 +43,6 @@ prepare() {
# hack! - some configure tests for header files using "$CPP $CPPFLAGS"
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" {libiberty,gcc}/configure
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=66035
- patch -p1 -i ${srcdir}/pr66035.patch
-
mkdir ${srcdir}/gcc-build
}
@@ -78,8 +74,7 @@ build() {
--disable-lto --disable-plugin --enable-install-libiberty \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \
- --enable-checking=release \
- --with-default-libstdcxx-abi=gcc4-compatible
+ --enable-checking=release
make all-gcc all-target-libgcc
}