summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2279763986a1..e106b889dd13 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,22 +7,24 @@ _reldate=20${_relshortdate}
_relverdate=${_relver}-${_reldate}
# This is how I want to define the pkgver, but the AUR doesn't understand it, because multiple _ characters are not allowed
#pkgver=${_relver}_${_reldate//-/_}
-pkgver=4.9_2014.09
+pkgver=4.9_2015.06
pkgrel=1
-_newlibver=linaro-2.1.0-2014.09
+_newlibver=linaro-2.2.0-2015.01
+_newlibvershort=15.01
#_newlibver=2.0.0
pkgdesc="The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target."
arch=(i686 x86_64)
url="https://releases.linaro.org/"
license=('GPL' 'LGPL')
groups=('arm-none-eabi-toolchain')
-depends=('arm-none-eabi-binutils>=2.23.2' 'gmp' 'mpfr' 'libmpc')
+depends=('arm-none-eabi-binutils>=2.26-1' 'gmp' 'mpfr' 'libmpc')
makedepends=('flex' 'bison')
provides=('arm-none-eabi-gcc')
conflicts=('arm-none-eabi-gcc' 'cross-arm-none-eabi-gcc')
options=(staticlibs !libtool !emptydirs !strip zipman docs)
source=(http://releases.linaro.org/${_relshortdate}/components/toolchain/gcc-linaro/${_relver}/gcc-linaro-${_relverdate}.tar.xz
- http://releases.linaro.org/14.09/components/toolchain/newlib-linaro/newlib-${_newlibver}.tar.bz2
+ http://releases.linaro.org/${_newlibvershort}/components/toolchain/newlib-linaro/newlib-${_newlibver}.tar.xz
+ gcc-4.9-fix-build-with-gcc-6.patch
gcc-${_relver}-multilib2.patch
gcc-${_relver}-no-exceptions.patch)
_basedir=gcc-linaro-${_relverdate}
@@ -38,10 +40,12 @@ _reldate=20${_relshortdate}
cd ${srcdir}/${_basedir}
patch -Np0 -i "${srcdir}/gcc-${_relver}-multilib2.patch"
patch -Np0 -i "${srcdir}/gcc-${_relver}-no-exceptions.patch"
+ patch -Np0 -i "${srcdir}/gcc-4.9-fix-build-with-gcc-6.patch"
mkdir build
cd build
+# --build=${CHOST} \
export CFLAGS="-O2"
export CXXFLAGS="-O2"
unset CPPFLAGS
@@ -82,7 +86,7 @@ package() {
# vim: set ts=2 sw=2 ft=sh et:
sha256sums=('c708c486f62f0d283f8615d7bc05d9830d50e15c52cfe213ec3992f6c190c222'
- 'ed92e8547246834725a3c5743fa41d3f573e3e5d2e5066d433ac3c29e6676fc8'
+ 'd29fe53d70f545c2fb080b9686e05d0f8af5088fec9b7dc78bc788a98765ef99'
+ 'b328e9cdca4e2869490d932191b78ef1a61c60382cea3a23d1ef86e7c1fb86a7'
'104b9aa652804a56338470983e6975af1d1e5440eb8bddae3a01a966d2b332cf'
'3a1d6a17aba8a578ade3552a6d1beb66a129fb4f3268539596d39cbbef88ac6c')
-