summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD45
1 files changed, 24 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72cf68f8ba75..b540e3e11b9a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,41 @@
# Maintainer: Timo Sarawinski <t.sarawinski@gmail.com>
-# Latest sources are at http://snapshots.linaro.org/components/toolchain/gcc-linaro/
+# Latest sources are at http://releases.linaro.org/components/toolchain/gcc-linaro/
pkgname=arm-none-eabi-gcc60-linaro
-_relver=snapshot-6.4
-_relshortdate=18.04
+_relver=6.5
+_relshortdate=18.12
_reldate=20${_relshortdate}
_relverdate=${_relver}-${_reldate}
# This is how I want to define the pkgver, but the AUR doesn't understand it, because multiple _ characters are not allowed
#pkgver=${_relver}_${_reldate//-/_}
-pkgver=6.4_2018.04
-_pkgver=6.4-2018.04
+pkgver=6.5_2018.12
+_pkgver=6.5-2018.12
pkgrel=1
pkgdesc="The GNU Compiler Collection - cross compiler for ARM EABI (bare-metal) target."
arch=(i686 x86_64)
url="https://releases.linaro.org/"
license=('GPL' 'LGPL')
groups=('arm-none-eabi-toolchain')
-depends=('arm-none-eabi-linaro-binutils' 'isl19' 'mpc' 'gmp' 'cloog' 'arm-none-eabi-newlib-linaro-git' 'mpfr' 'libmpc')
+depends=('arm-none-eabi-linaro-binutils>=2.26-1' 'isl>=0.14' 'mpc' 'gmp' 'cloog' 'arm-none-eabi-newlib-linaro-git' 'mpfr' 'libmpc')
makedepends=('gcc-ada' 'expect' 'flex' 'bison')
#provides=('arm-none-eabi-gcc')
#conflicts=('arm-none-eabi-gcc' 'cross-arm-none-eabi-gcc')
options=(staticlibs !libtool !emptydirs !strip zipman docs)
-source=(http://snapshots.linaro.org/components/toolchain/gcc-linaro/${_pkgver}/gcc-linaro-${_relverdate}.tar.xz
+source=(http://releases.linaro.org/components/toolchain/gcc-linaro/${_pkgver}/gcc-linaro-${_pkgver}.tar.xz
0200-gcc-no-exceptions.patch
0300-gcc-multilib2.patch
- 0400-enable-with-multilib-list-for-arm.patch
- 1039-libcc1-fix-libcc1-s-install-path-and-rpath.patch)
+ 1039-libcc1-fix-libcc1-s-install-path-and-rpath.patch
+ 0400-enable-with-multilib-list-for-arm.patch
+ )
_basedir=gcc-linaro-${_relverdate}
-sha256sums=('b557579608963941647d06281a08a4499216957ceae6f02e040c32cdda3bca22'
+sha256sums=('3c5a620e36d61752136197d9abe231ab37f5bc9c500410d21b75b4322df305ef'
'76eab14830216c774291d2ac35d4b4690f3273aa8c630a2c1546f02538847d8a'
'c9b6bc1dd53f9b4b80f5fdacdef94c9fce0e516c16fb78063107b66ba2e9fdd1'
- '9447a8fd40d7c1e238b8e9790b739492de5feaa489d61f4ecdab863e5ea1975a'
- 'fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07')
+ 'fa08269d6a748631b07b55a5fe00fa518b2f6e04356a3d6634c60f3c3ece3b07'
+ '9447a8fd40d7c1e238b8e9790b739492de5feaa489d61f4ecdab863e5ea1975a')
build() {
- cd ${srcdir}
cd ${srcdir}/${_basedir}
find ${srcdir}/*.patch | while read PATCH ; do
@@ -49,14 +49,14 @@ cd ${srcdir}/${_basedir}
unset CPPFLAGS
../configure --with-pkgversion="Arch User Repository" \
--with-bugurl="https://aur.archlinux.org/packages/arm-none-eabi-gcc-linaro" \
- --target=arm-none-eabi\
+ --target=arm-none-eabi \
--prefix=/usr \
--libexecdir=/usr/lib \
--datarootdir=/usr/share/arm-none-eabi-gcc-6 \
--enable-multilib \
--enable-languages=c,c++ \
--enable-interwork \
- --program-prefix=arm-none-eabi- \
+ --program-prefix=arm-none-eabi- \
--program-suffix=-6 \
--enable-vtable-verify \
--with-newlib \
@@ -66,19 +66,22 @@ cd ${srcdir}/${_basedir}
--disable-nls \
--disable-shared \
--enable-threads \
- --enable-lto \
+ --enable-lto \
--disable-libssp \
+ --disable-libstdcxx \
--disable-libstdcxx-pch \
- --disable-libstdc__-v3 \
- --disable-libmudflap \
- --disable-libgomp \
- --enable-gold \
+ --enable-gold \
--enable-silent-rules \
- --with-headers=/usr/arm-none-eabi/include \
--disable-newlib-supplied-syscalls
make
}
+check() {
+cd ${srcdir}/${_basedir}
+cd build
+make -j5 check
+}
+
package() {
cd ${srcdir}/${_basedir}/build
make -j1 DESTDIR=${pkgdir} install