summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64ff68d2bafe..e1869167746f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Jonathan la Cour <jon@lacour.me>
+# Contributor: Jonathan la Cour <jon@lacour.me>
# Contributor: Patrick Glandien <patrick@synix.io>
# Contributor: William Grieshaber <me@zee.li>
# Contributor: portals <portals at riseup.net> Base on work of: 2bluesc <2bluesc at gmail.com> and mazzolino <maze+aur at strahlungsfrei.de>
@@ -6,13 +6,13 @@
pkgname=armory
pkgver=0.96.5
-pkgrel=1
+pkgrel=2
pkgdesc="Full-featured Bitcoin wallet management application"
arch=('i686' 'x86_64')
url="https://github.com/goatpig/BitcoinArmory"
license=('AGPL3' 'MIT')
-depends=('crypto++' 'swig' 'qt4' 'python2' 'python2-twisted' 'python2-pyqt4' 'python2-bsddb' 'python2-psutil')
-makedepends=('gcc' 'make')
+depends=('crypto++' 'qt4' 'python2' 'python2-twisted' 'python2-pyqt4' 'python2-bsddb' 'python2-psutil')
+makedepends=('gcc' 'make' 'swig3')
optdepends=('bitcoin-daemon: Communicate with the Bitcoin network')
provides=('armory')
conflicts=('armory' 'armory-git' 'armory-bin' 'armory-goatpig-git')
@@ -23,9 +23,11 @@ install="${pkgname}.install"
_signatures="https://github.com/goatpig/BitcoinArmory/releases/download/v${pkgver}/sha256sum.txt.asc"
source=("https://github.com/goatpig/BitcoinArmory/releases/download/v${pkgver}/armory_${pkgver}_source.tar.xz"
'0001-Fix-compilation.patch'
+ '0002-Use-swig3.0.patch'
'run-armory.sh')
sha512sums=('aba9627a58414d9a5b9781753d6c09b3970f2728f317419b3dc8547a8ad2b9e7f9615a650a56441122647406ea846c64383677f220f26ef395029cdb8d25812c'
'10d10d449652de81d2bdeff5cd2bc72015071354720b80650a243f51a16e2b6da8f0600134ab03364819d0e916ae368a1ef81a5df71cddbf48fe9c1980e99dff'
+ 'eb8f4d55495642747dd4777ebeed309b8b9dbc2a07294748ea2f2c7e97d35111dc4156eeda4c668a624bd05d5ea44957dfbc930484fc1fa0b487661cee7fac18'
'af44a8edfdf751f3343a8bdf6fa21c125389de3435c4b03c7f581b980525a9f32af177f496830f847b70c8e2619c42908536698e0fd28f862f16083cf7396715')
_parentdir=Armory3
@@ -46,7 +48,8 @@ check() {
prepare() {
cd "$srcdir/$_parentdir"
- patch --strip=1 --input=../../0001-Fix-compilation.patch
+ patch --strip=1 --input=../0001-Fix-compilation.patch
+ patch --strip=1 --input=../0002-Use-swig3.0.patch
## Get Python2 Version
_py2longver=$(pacman -Qi python2 | grep "Version" | sed 's/^Version\s*:\s//')